dev-erlang/esip: Bump version to 1.0.8
[gentoo.git] / dev-erlang / esip / esip-1.0.7.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit rebar
8
9 DESCRIPTION="ProcessOne SIP server component"
10 HOMEPAGE="https://github.com/processone/esip"
11 SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
12         -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
17
18 DEPEND=">=dev-erlang/fast_tls-1.0.6
19         >=dev-erlang/stun-1.0.6
20         >=dev-erlang/p1_utils-1.0.4
21         >=dev-lang/erlang-17.1"
22 RDEPEND="${DEPEND}"
23
24 DOCS=( CHANGELOG.md  README.md )
25
26 src_prepare() {
27         rebar_src_prepare
28         rebar_fix_include_path stun
29
30         # ebin contains lonely .gitignore file asking for removal.
31         rm -r "${S}/ebin" || die
32 }