dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-erlang / epam / epam-1.0.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit rebar user
7
8 DESCRIPTION="epam for ejabberd to help with PAM authentication support"
9 HOMEPAGE="https://github.com/processone/epam"
10 SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
11         -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
16
17 DEPEND=">=dev-lang/erlang-17.1
18         sys-libs/pam"
19 RDEPEND="${DEPEND}"
20
21 DOCS=( CHANGELOG.md README.md )
22
23 pkg_setup() {
24         enewgroup "${PN}"
25 }
26
27 src_install() {
28         rebar_src_install
29
30         local epam_path="$(get_erl_libs)/${P}/priv/bin/epam"
31         fowners root:"${PN}" "${epam_path}"
32         fperms 4750 "${epam_path}"
33 }