Merge remote-tracking branch 'github/pr/463'.
[gentoo.git] / dev-embedded / usbprog / usbprog-0.2.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 DESCRIPTION="flashtool for the multi purpose programming adapter usbprog"
8 HOMEPAGE="http://www.embedded-projects.net/index.php?page_id=215"
9 #SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
10 SRC_URI="mirror://gentoo/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="static-libs X"
16
17 RDEPEND="X? ( >=x11-libs/wxGTK-2.6.0 )
18         >=dev-libs/libxml2-2.0.0
19         net-misc/curl
20         virtual/libusb:0
21         sys-libs/readline"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig"
24
25 src_configure() {
26         econf \
27                 $(use_enable X gui) \
28                 $(use_enable static-libs static)
29 }
30
31 src_install() {
32         default
33         use static-libs || find "${ED}" -name '*.la' -delete
34 }