dev-perl/CPAN-Uploader: Fix ebuild.badheader
[gentoo.git] / dev-embedded / sgpp-lite-arm-uclinux-bin / sgpp-lite-arm-uclinux-bin-2010.09.58.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 CPU="arm"
5 TARGET="arm-uclinuxeabi"
6 HOST="i686-pc-linux-gnu"
7 MY_P="${CPU}-${PV%.*}-${PV##*.}-${TARGET}-${HOST}"
8
9 DESCRIPTION="Regular, validated releases of the GNU Toolchain for ${CPU} processors"
10 HOMEPAGE="http://www.codesourcery.com/sgpp/lite/${CPU}"
11 SRC_URI="http://www.codesourcery.com/public/gnu_toolchain/${TARGET}/${MY_P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="${PV}"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17 RESTRICT="strip" # package is already stripped, and contains target bins
18 QA_EXECSTACK="opt/${P}/*"
19
20 RDEPEND="sys-libs/glibc"
21 DEPEND=""
22
23 S=${WORKDIR}/${CPU}-${PV%.*}
24
25 src_install() {
26         local d="/opt/${P}"
27         dodir ${d}
28         cp -pPR * "${D}"/${d}/ || die
29
30         pushd "${D}"/${d}/share/doc/${CPU}-${TARGET} >/dev/null
31         if use doc ; then
32                 dohtml -r html/* || die
33                 dodoc pdf/* || die
34         fi
35         rm -rf html pdf
36         rm LICENSE.txt man/man7/{fsf-funding,gpl,gfdl}.7 || die
37         mv man info ../..
38         popd >/dev/null
39         find "${D}" -depth -type d -empty -delete
40
41         cat <<-EOF > "${T}"/15${P}
42         PATH=${d}/bin
43         MANPATH=${d}/share/man
44         INFOPATH=${d}/share/info
45         EOF
46         doenvd "${T}"/15${P} || die
47 }