Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / dev-embedded / scratchbox-devkit-perl / scratchbox-devkit-perl-1.0.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 SBOX_GROUP="sbox"
6
7 DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier"
8 HOMEPAGE="http://www.scratchbox.org/"
9 SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/${P}-i386.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 # Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
16 RESTRICT="strip"
17
18 RDEPEND="=dev-embedded/scratchbox-1.0*"
19 DEPEND=""
20
21 TARGET_DIR="/opt/scratchbox"
22
23 S=${WORKDIR}/scratchbox
24
25 src_install() {
26         dodir ${TARGET_DIR}
27         cp -pRP * "${D}/${TARGET_DIR}"
28 }