dev-qt/qtnetwork: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-embedded / parapin / parapin-1.5.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="A parallel port pin programming library"
8 HOMEPAGE="http://parapin.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
10
11 LICENSE="LGPL-2.1"
12 IUSE="doc"
13 KEYWORDS="~amd64 ~x86"
14 SLOT="0"
15
16 DEPEND="doc? ( dev-tex/latex2html )"
17
18 src_compile() {
19         # Note 2.4 and 2.6 makefiles are identical for the targets used
20         emake -f Makefile-2.4 CC=$(tc-getCC)
21         use doc && emake -C doc html
22 }
23
24 src_install() {
25         dolib.a libparapin.a
26         insopts -m0444; insinto /usr/include; doins parapin.h
27
28         dodoc README
29         if use doc; then
30                 cd "${S}"/doc/${PN}
31                 docinto html
32                 dodoc *.html *.css *.png
33
34                 cd "${S}"/examples
35                 docinto examples
36                 dodoc *.c
37         fi
38 }