01df7e182c0caf611710befb27e8b7f9b81a3e4d
[gentoo.git] / dev-embedded / esptool / esptool-2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
11 HOMEPAGE="https://github.com/espressif/esptool"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~x86"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND="${DEPEND}
21         dev-python/ecdsa[${PYTHON_USEDEP}]
22         dev-python/pyaes[${PYTHON_USEDEP}]
23         >=dev-python/pyserial-2.5[${PYTHON_USEDEP}]"
24
25 RESTRICT="test" # Uses a device connected to the serial port
26
27 python_test() {
28         ${EPYTHON} test/test_esptool.py || die
29 }