sys-libs/libomp: Bump to 7.0.0rc3
[gentoo.git] / dev-embedded / avra / avra-1.3.0.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit autotools
7
8 DESCRIPTION="Atmel AVR Assembler"
9 HOMEPAGE="http://avra.sourceforge.net"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15 IUSE="doc examples"
16
17 S="${WORKDIR}/${P}/src/"
18
19 src_prepare() {
20         eautoreconf
21 }
22
23 src_install() {
24         local datadir="${WORKDIR}/${P}"
25
26         default
27
28         dodoc ${datadir}/{AUTHORS,INSTALL,README,TODO}
29
30         # install headers
31         insinto /usr/include/avr
32         doins "${datadir}/includes/"*
33
34         use doc && dohtml -r "${datadir}/doc/"*
35
36         if use examples; then
37                 insinto /usr/share/doc/${PF}/examples
38                 doins "${datadir}/examples/"*
39         fi
40 }