Merge remote-tracking branch 'github/pr/2627'
[gentoo.git] / dev-dotnet / gkeyfile-sharp / gkeyfile-sharp-0.1-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools mono-env
7
8 DESCRIPTION="C# binding for gkeyfile"
9 HOMEPAGE="https://launchpad.net/gkeyfile-sharp https://github.com/mono/gkeyfile-sharp"
10 SRC_URI="https://github.com/mono/${PN}/tarball/GKEYFILE_SHARP_0_1 -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 RDEPEND="|| ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/glib-sharp-2.12.9 )
18         || ( >=dev-dotnet/gtk-sharp-2.12.21 >=dev-dotnet/gtk-sharp-gapi-1.9 )"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 src_unpack() {
23         unpack ${A}
24         mv *-${PN}-* "${S}"
25 }
26
27 src_prepare() {
28         mv configure.in configure.ac
29         sed -i -e 's/gmcs/mcs/' configure.ac || die
30         eautoreconf
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35         dodoc AUTHORS ChangeLog NEWS
36 }