dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-db / sqliteman / sqliteman-1.2.2-r4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 QT_VER=5.7.1
7 inherit cmake-utils flag-o-matic xdg-utils
8
9 DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
10 HOMEPAGE="https://sourceforge.net/projects/sqliteman/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm x86"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-qt/qtcore-${QT_VER}:5
20         >=dev-qt/qtgui-${QT_VER}:5
21         >=dev-qt/qtsql-${QT_VER}:5[sqlite]
22         >=dev-qt/qtwidgets-${QT_VER}:5
23         >=x11-libs/qscintilla-2.9.4:=[qt5(+)]"
24 DEPEND="${RDEPEND}"
25
26 PATCHES=(
27         "${FILESDIR}/${P}-lpthread.patch"
28         "${FILESDIR}/${P}-qt5.patch"
29 )
30
31 src_prepare() {
32         # remove bundled lib
33         rm -rf "${S}"/${PN}/qscintilla2 || die
34
35         append-flags -fPIC
36         cmake-utils_src_prepare
37 }
38
39 pkg_postinst() {
40         xdg_desktop_database_update
41 }
42
43 pkg_postrm() {
44         xdg_desktop_database_update
45 }