Merge branch 'zasdfgbnm-master'
[gentoo.git] / dev-db / spatialite / spatialite-3.0.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 MY_PN="lib${PN}"
8 MY_P="${MY_PN}-${PV}"
9
10 inherit multilib
11
12 DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
13 HOMEPAGE="http://www.gaia-gis.it/gaia-sins/"
14 SRC_URI="http://www.gaia-gis.it/gaia-sins/${MY_PN}-sources/${MY_P}.tar.gz"
15
16 LICENSE="MPL-1.1"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
19 IUSE="+geos iconv +proj +xls"
20
21 RDEPEND=">=dev-db/sqlite-3.7.5:3[extensions(+)]
22         geos? ( >=sci-libs/geos-3.3 )
23         proj? ( sci-libs/proj )
24         xls? ( dev-libs/freexl )
25 "
26 DEPEND="${RDEPEND}"
27
28 S=${WORKDIR}/${MY_P}
29
30 src_configure() {
31         econf \
32                 --disable-static \
33                 --enable-geocallbacks \
34                 --enable-epsg \
35                 $(use_enable geos) \
36                 $(use_enable geos geosadvanced) \
37                 $(use_enable iconv) \
38                 $(use_enable proj) \
39                 $(use_enable xls freexl)
40 }
41
42 src_install() {
43         default
44
45         find "${ED}" -name '*.la' -exec rm -f {} +
46 }