net-p2p/amule: Resolve merge conflicts.
[gentoo.git] / dev-db / spatialite / spatialite-2.4.0_rc4.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 MY_PV=${PV/_rc/-}
8 MY_P=lib${P/_rc*}
9
10 inherit multilib
11
12 DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
13 HOMEPAGE="http://www.gaia-gis.it/gaia-sins/"
14 SRC_URI="http://www.gaia-gis.it/${PN}-${MY_PV}/${MY_P}.tar.gz"
15
16 LICENSE="MPL-1.1"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19 IUSE="+geos iconv +proj"
20
21 RDEPEND=">=dev-db/sqlite-3.7.5:3[extensions(+)]
22         geos? ( sci-libs/geos )
23         proj? ( sci-libs/proj )"
24 DEPEND="${RDEPEND}"
25
26 S=${WORKDIR}/${MY_P}
27
28 src_configure() {
29         econf \
30                 --disable-static \
31                 --enable-geocallbacks \
32                 --enable-epsg \
33                 $(use_enable geos) \
34                 $(use_enable iconv) \
35                 $(use_enable proj)
36 }
37
38 src_install() {
39         default
40
41         find "${ED}" -name '*.la' -exec rm -f {} +
42 }