dev-db/redis: x86 stable wrt bug #614182
[gentoo.git] / dev-db / oracle-instantclient-jdbc / oracle-instantclient-jdbc-11.2.0.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils multilib
5
6 MY_P_x86="${PN/oracle-/}-linux32-${PV}.0"
7 MY_P_amd64="${PN/oracle-instantclient-/instantclient-}-linux-x86-64-${PV}.0"
8
9 S="${WORKDIR}"
10 DESCRIPTION="Oracle 11g client installation for Linux: JDBC supplement"
11 HOMEPAGE="http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html"
12 SRC_URI="x86? ( ${MY_P_x86}.zip )
13                 amd64? ( ${MY_P_amd64}.zip )"
14
15 LICENSE="OTN"
16 SLOT="0"
17 KEYWORDS="~x86 ~amd64"
18 RESTRICT="fetch"
19 IUSE=""
20
21 RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
22 DEPEND="${RDEPEND}
23         app-arch/unzip"
24
25 pkg_setup() {
26         MY_P=MY_P_${ARCH}
27         export MY_P=${!MY_P}
28 }
29
30 pkg_nofetch() {
31         eerror "Please go to:"
32         eerror "  ${HOMEPAGE}"
33         eerror "and download the JDBC supplemental package.  Put it in:"
34         eerror "  ${DISTDIR}"
35         eerror "after downloading it."
36 }
37
38 src_unpack() {
39         unzip "${DISTDIR}"/${MY_P}.zip
40 }
41
42 src_install() {
43         dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
44         cd "${S}"/instantclient_11_2
45         insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
46         doins libheteroxa11.so orai18n.jar
47 }
48
49 pkg_postinst() {
50         elog "The JDBC supplement package for Oracle 11g has been installed."
51         elog "You may wish to install the oracle-instantclient-sqlplus (for "
52         elog "running the SQL*Plus application) package as well."
53 }