dev-db/phpmyadmin: x86 stable wrt bug #573286
[gentoo.git] / dev-db / opendbx / opendbx-1.4.5-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit flag-o-matic multilib
8
9 DESCRIPTION="OpenDBX - A database abstraction layer"
10 HOMEPAGE="http://www.linuxnetworks.de/doc/index.php/OpenDBX"
11 SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="firebird +mysql oracle postgres sqlite"
17 RESTRICT="firebird? ( bindist )"
18
19 DEPEND="mysql? ( virtual/mysql )
20         postgres? ( dev-db/postgresql:* )
21         sqlite? ( dev-db/sqlite:3 )
22         oracle? ( dev-db/oracle-instantclient-basic )
23         firebird? ( dev-db/firebird )"
24 RDEPEND="${DEPEND}"
25
26 pkg_setup() {
27         if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
28         then
29                 ewarn "You should enable at least one of the following USE flags:"
30                 ewarn "firebird, mysql, oracle, postgres or sqlite"
31         fi
32
33         if use oracle && [[ ! -d ${ORACLE_HOME} ]]
34         then
35                 die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
36         fi
37
38         use mysql && append-cppflags -I/usr/include/mysql
39         use firebird && append-cppflags -I/opt/firebird/include
40         use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
41 }
42
43 src_configure() {
44         local backends=""
45
46         use firebird && backends="${backends} firebird"
47         use mysql && backends="${backends} mysql"
48         use oracle && backends="${backends} oracle"
49         use postgres && backends="${backends} pgsql"
50         use sqlite && backends="${backends} sqlite3"
51
52         econf --with-backends="${backends}"
53 }
54
55 src_compile() {
56         # bug #322221
57         emake -j1
58 }
59
60 src_install() {
61         emake -j1 install DESTDIR="${D}"
62         dodoc AUTHORS ChangeLog README
63
64         rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
65 }