profiles/arch/ia64/use.mask: add reference to python mask
[gentoo.git] / dev-db / mysql++ / mysql++-3.2.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools libtool flag-o-matic
7
8 DESCRIPTION="C++ API interface to the MySQL database"
9 HOMEPAGE="http://tangentsoft.net/mysql++/"
10 SRC_URI="http://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"
11
12 LICENSE="LGPL-2"
13 SLOT="0/3"
14 KEYWORDS="~alpha amd64 hppa ~mips ppc sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
15 IUSE="doc"
16
17 RDEPEND="dev-db/mysql-connector-c:="
18 DEPEND="${RDEPEND}"
19 DOCS=( CREDITS.txt HACKERS.txt Wishlist doc/ssqls-pretty )
20 PATCHES=(
21         "${FILESDIR}"/${PN}-3.2.1-gold.patch
22         "${FILESDIR}"/${PN}-3.2.3-mariadb-10.2.patch
23         "${FILESDIR}"/${PN}-3.2.3-as-needed.patch
24 )
25
26 src_prepare() {
27         # Bug filed upstream about deprecated std::auto_ptr
28         append-cxxflags $(test-flags-CXX -Wno-deprecated-declarations)
29         # Bad symlink for libtool in the archive
30         rm "${S}/ltmain.sh" || die
31
32         default
33
34         _elibtoolize --auto-ltdl --install --copy --force
35         elibtoolize
36         # Current MySQL libraries are always with threads and slowly being removed
37         sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
38         rm "${S}/doc/"README-*-RPM.txt || die
39 }
40
41 src_configure() {
42         local myconf=(
43                 --enable-thread-check
44                 --with-mysql="${EPREFIX}/usr"
45                 --with-mysql-lib="${EPREFIX}$(mysql_config --variable=pkglibdir)"
46                 --with-mysql-include="${EPREFIX}$(mysql_config --variable=pkgincludedir)"
47         )
48         econf "${myconf[@]}"
49 }
50
51 src_install() {
52         default
53         # install the docs and HTML pages
54         use doc && dodoc -r doc/pdf/ doc/refman/ doc/userman/ doc/html/
55 }