dev-db/redis: bump to 5.0.9
[gentoo.git] / dev-db / influxdb / influxdb-1.6.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGO_PN=github.com/influxdata/${PN}
7 EGO_VENDOR=(
8 "collectd.org e84e8af5356e7f47485bbc95c96da6dd7984a67e github.com/collectd/go-collectd"
9 "github.com/BurntSushi/toml a368813c5e648fee92e5f6c30e3944ff9d5e8895"
10 "github.com/RoaringBitmap/roaring cefad6e4f79d4fa5d1d758ff937dde300641ccfa"
11 "github.com/beorn7/perks 4c0e84591b9aa9e6dcfdf3e020114cd81f89d5f9"
12 "github.com/bmizerany/pat c068ca2f0aacee5ac3681d68e4d0a003b7d1fd2c"
13 "github.com/boltdb/bolt 4b1ebc1869ad66568b313d0dc410e2be72670dda"
14 "github.com/cespare/xxhash 1b6d2e40c16ba0dfce5c8eac2480ad6e7394819b"
15 "github.com/davecgh/go-spew 346938d642f2ec3594ed81d874461961cd0faa76"
16 "github.com/dgrijalva/jwt-go 24c63f56522a87ec5339cc3567883f1039378fdb"
17 "github.com/dgryski/go-bits 2ad8d707cc05b1815ce6ff2543bb5e8d8f9298ef"
18 "github.com/dgryski/go-bitstream 7d46cd22db7004f0cceb6f7975824b560cf0e486"
19 "github.com/glycerine/go-unsnap-stream 62a9a9eb44fd8932157b1a8ace2149eff5971af6"
20 "github.com/gogo/protobuf 1c2b16bc280d6635de6c52fc1471ab962dc36ec9"
21 "github.com/golang/protobuf 1e59b77b52bf8e4b449a57e6f79f21226d571845"
22 "github.com/golang/snappy d9eb7a3d35ec988b8585d4a0068e462c27d28380"
23 "github.com/google/go-cmp 18107e6c56edb2d51f965f7d68e59404f0daee54"
24 "github.com/influxdata/influxql 21ddebb5641365d9b92234e8f5a566c41da9ab48"
25 "github.com/influxdata/usage-client 6d3895376368aa52a3a81d2a16e90f0f52371967"
26 "github.com/influxdata/yamux 1f58ded512de5feabbe30b60c7d33a7a896c5f16"
27 "github.com/influxdata/yarpc 036268cdec22b7074cd6d50cc6d7315c667063c7"
28 "github.com/jsternberg/zap-logfmt 5ea53862c7fa897f44ae0b3004283308c0b0c9d1"
29 "github.com/jwilder/encoding 27894731927e49b0a9023f00312be26733744815"
30 "github.com/mattn/go-isatty 6ca4dbf54d38eea1a992b3c722a76a5d1c4cb25c"
31 "github.com/matttproud/golang_protobuf_extensions c12348ce28de40eed0136aa2b644d0ee0650e56c"
32 "github.com/opentracing/opentracing-go 1361b9cd60be79c4c3a7fa9841b3c132e40066a7"
33 "github.com/paulbellamy/ratecounter 5a11f585a31379765c190c033b6ad39956584447"
34 "github.com/peterh/liner 88609521dc4b6c858fd4c98b628147da928ce4ac"
35 "github.com/philhofer/fwd 1612a298117663d7bc9a760ae20d383413859798"
36 "github.com/prometheus/client_golang 661e31bf844dfca9aeba15f27ea8aa0d485ad212"
37 "github.com/prometheus/client_model 99fa1f4be8e564e8a6b613da7fa6f46c9edafc6c"
38 "github.com/prometheus/common 2e54d0b93cba2fd133edc32211dcc32c06ef72ca"
39 "github.com/prometheus/procfs a6e9df898b1336106c743392c48ee0b71f5c4efa"
40 "github.com/retailnext/hllpp 38a7bb71b483e855d35010808143beaf05b67f9d"
41 "github.com/tinylib/msgp ad0ff2e232ad2e37faf67087fb24bf8d04a8ce20"
42 "github.com/xlab/treeprint 06dfc6fa17cdde904617990a0c2d89e3e332dbb3"
43 "go.uber.org/atomic 54f72d32435d760d5604f17a82e2435b28dc4ba5 github.com/uber-go/atomic"
44 "go.uber.org/multierr fb7d312c2c04c34f0ad621048bbb953b168f9ff6 github.com/uber-go/multierr"
45 "go.uber.org/zap 35aad584952c3e7020db7b839f6b102de6271f89 github.com/uber-go/zap"
46 "golang.org/x/crypto 9477e0b78b9ac3d0b03822fd95422e2fe07627cd github.com/golang/crypto"
47 "golang.org/x/net 9dfe39835686865bff950a07b394c12a98ddc811 github.com/golang/net"
48 "golang.org/x/sync fd80eb99c8f653c847d294a001bdf2a3a6f768f5 github.com/golang/sync"
49 "golang.org/x/sys 062cd7e4e68206d8bab9b18396626e855c992658 github.com/golang/sys"
50 "golang.org/x/text a71fd10341b064c10f4a81ceac72bcf70f26ea34 github.com/golang/text"
51 "golang.org/x/time 6dc17368e09b0e8634d71cac8168d853e869a0c7 github.com/golang/time"
52         )
53
54 inherit golang-build golang-vcs-snapshot systemd user
55
56 DESCRIPTION=" Scalable datastore for metrics, events, and real-time analytics"
57 HOMEPAGE="https://www.influxdata.com"
58 SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
59         ${EGO_VENDOR_URI}"
60
61 LICENSE="MIT BSD Apache-2.0 EPL-1.0 MPL-2.0 MIT-with-advertising BSD-2 ISC"
62 SLOT="0"
63 KEYWORDS="~amd64"
64 IUSE=""
65
66 DEPEND=">=app-text/asciidoc-8.6.10
67         app-text/xmlto"
68
69 pkg_setup() {
70         enewgroup influxdb
71         enewuser influxdb -1 -1 /var/lib/influxdb influxdb
72 }
73
74 src_compile() {
75         pushd "src/${EGO_PN}" > /dev/null || die
76         set -- env GOPATH="${S}" go build -v -work -x ./...
77         echo "$@"
78         "$@" || die "compile failed"
79         cd man
80         emake build
81         popd > /dev/null
82 }
83
84 src_install() {
85         pushd "src/${EGO_PN}" > /dev/null || die
86         set -- env GOPATH="${S}" go install -v -work -x ./...
87         echo "$@"
88         "$@" || die
89         dobin "${S}"/bin/influx*
90         dodoc CHANGELOG.md etc/config.sample.toml
91         doman man/*.1
92         insinto /etc/logrotate.d
93         newins scripts/logrotate influxdb
94         systemd_dounit scripts/influxdb.service
95         newconfd "${FILESDIR}"/influxdb.confd influxdb
96         newinitd "${FILESDIR}"/influxdb.rc influxdb
97         insinto /etc/influxdb
98         doins "${FILESDIR}"/influxd.conf
99         keepdir /var/log/influxdb
100         fowners influxdb:influxdb /var/log/influxdb
101         popd > /dev/null || die
102 }