dev-libs/leatherman: remove installing vendored boost library
[gentoo.git] / dev-db / gqlplus / gqlplus-1.16.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools
7
8 DESCRIPTION="a front-end for Oracle program sqlplus with command-line editing"
9 HOMEPAGE="https://sourceforge.net/projects/gqlplus/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~amd64-linux ~x64-macos"
15 IUSE=""
16
17 DEPEND="sys-libs/readline:*"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         # don't use packaged readline and old version containing it
22         rm -Rf readline gqlplus-1.15
23
24         # maintainer can't seem to get versioning right
25         sed -i '/^#define VERSION/s/"[^"]\+"/"'"${PV}"'"/' gqlplus.c || die
26         sed -i '/^AC_INIT/s/\[[1-9.]\+\]/['"${PV}"']/' configure.ac || die
27         eautoreconf
28 }