mail-mta/postfix: arm stable wrt bug #724236
[gentoo.git] / dev-cpp / yaml-cpp / yaml-cpp-0.6.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CMAKE_ECLASS="cmake"
7 inherit cmake-multilib
8
9 DESCRIPTION="YAML parser and emitter in C++"
10 HOMEPAGE="https://github.com/jbeder/yaml-cpp"
11 SRC_URI="https://github.com/jbeder/${PN}/archive/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0/0.6"
15 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
16 IUSE="test"
17
18 # test breaks build
19 # RESTRICT="!test? ( test )"
20 RESTRICT+="test"
21
22 DEPEND="test? ( dev-cpp/gtest )"
23
24 S="${WORKDIR}/${PN}-${P}"
25
26 PATCHES=( "${FILESDIR}/${P}-abi-breakage.patch" )
27
28 src_prepare() {
29         sed -i \
30                 -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
31                 yaml-cpp.pc.cmake || die
32
33         cmake_src_prepare
34 }
35
36 src_configure() {
37         local mycmakeargs=(
38                 -DBUILD_SHARED_LIBS=ON
39                 -DYAML_BUILD_SHARED_LIBS=ON
40                 -DYAML_CPP_BUILD_TOOLS=OFF # Don't have install rule
41                 -DYAML_CPP_BUILD_TESTS=$(usex test)
42         )
43
44         cmake-multilib_src_configure
45 }