*/*: Switch candrews' packages to cmake.eclass
[gentoo.git] / dev-cpp / waylandpp / waylandpp-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 DESCRIPTION="Wayland C++ bindings"
9 HOMEPAGE="https://github.com/NilsBrause/waylandpp"
10
11 LICENSE="MIT"
12 IUSE="doc"
13 SLOT="0/$(ver_cut 1-2)"
14
15 if [[ ${PV} == *9999 ]] ; then
16         EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
17         inherit git-r3
18 else
19         SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
20         KEYWORDS="~amd64 ~x86"
21 fi
22
23 RDEPEND="
24         >=dev-libs/wayland-1.11.0
25         media-libs/mesa[wayland]
26         >=dev-libs/pugixml-1.9-r1
27 "
28 DEPEND="${RDEPEND}
29         doc? (
30                 app-doc/doxygen
31                 media-gfx/graphviz
32         )
33         "
34
35 src_configure() {
36         local mycmakeargs=(
37                 -DBUILD_DOCUMENTATION=$(usex doc)
38         )
39
40         cmake_src_configure
41 }