dev-cpp/tbb: version bump to 2020.1
[gentoo.git] / dev-cpp / pstreams / pstreams-0.7.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="C++ wrapper for the POSIX.2 functions popen(3) and pclose(3)"
9 HOMEPAGE="http://pstreams.sourceforge.net/"
10 SRC_URI="
11         mirror://sourceforge/${PN}/${P}.tar.gz
12         doc? ( mirror://sourceforge/${PN}/${PN}-docs-${PV}.tar.gz )"
13
14 SLOT="0"
15 LICENSE="LGPL-3"
16 IUSE="doc"
17 KEYWORDS="~amd64 ~x86"
18
19 RDEPEND=""
20 DEPEND="doc? ( app-doc/doxygen )"
21
22 src_compile() {
23         if use doc; then
24                 doxygen -u || die
25                 emake
26         fi
27 }
28
29 src_test() {
30         emake \
31                 CXX="$(tc-getCXX)" \
32                 CXXFLAGS="${CXXFLAGS}" \
33                 check
34 }
35
36 src_install() {
37         doheader pstream.h
38
39         dodoc AUTHORS ChangeLog README
40
41         use doc && dohtml -r "${WORKDIR}"/${PN}-docs-${PV}/*
42 }