dev-cpp/nlohmann_json: fix build with gcc-10
[gentoo.git] / dev-cpp / lucene++ / lucene++-3.0.7-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_P="LucenePlusPlus-rel_${PV}"
7 inherit cmake-utils
8
9 DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
10 HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
11 SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="|| ( LGPL-3 Apache-2.0 )"
14 SLOT="0"
15 KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
16 IUSE="debug"
17
18 DEPEND="dev-libs/boost:="
19 RDEPEND="${DEPEND}"
20
21 RESTRICT="test"
22
23 S="${WORKDIR}/${MY_P}"
24
25 DOCS=( AUTHORS README.rst )
26
27 PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
28
29 src_configure() {
30         local mycmakeargs=(
31                 -DENABLE_DEMO=OFF
32                 -DENABLE_TEST=OFF
33         )
34
35         cmake-utils_src_configure
36 }