*/*: gtkmm.org to https
[gentoo.git] / dev-cpp / gnome-vfsmm / gnome-vfsmm-2.26.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 GCONF_DEBUG="no"
6 GNOME_TARBALL_SUFFIX="bz2"
7
8 inherit flag-o-matic gnome2
9
10 DESCRIPTION="C++ bindings for gnome-vfs"
11 HOMEPAGE="https://www.gtkmm.org"
12
13 LICENSE="LGPL-2.1"
14 SLOT="1.1"
15 KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
16 IUSE="doc examples"
17
18 # glibmm dep is because build fails with older versions...
19 RDEPEND="
20         >=gnome-base/gnome-vfs-2.8.1
21         >=dev-cpp/glibmm-2.12
22 "
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         doc? ( app-doc/doxygen )
26 "
27
28 src_prepare() {
29         if ! use doc; then
30                 # documentation requires Doxygen and takes time
31                 sed -i 's/^\(SUBDIRS =.*\)docs\(.*\)$/\1\2/' Makefile.in || \
32                         die "sed Makefile.in failed"
33         fi
34
35         if ! use examples; then
36                 # don't waste time building the examples
37                 sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
38                         die "sed Makefile.in failed"
39         fi
40
41         append-cxxflags -std=c++11
42
43         gnome2_src_prepare
44 }
45
46 src_install() {
47         gnome2_src_install
48
49         if use doc ; then
50                 dohtml -r docs/reference/html/*
51         fi
52
53         if use examples; then
54                 find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
55                 cp -R examples "${ED}"/usr/share/doc/${PF}
56         fi
57 }