dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ada / gnat_util / gnat_util-2018-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ADA_COMPAT=( gnat_201{8,9} )
7 inherit ada toolchain-funcs multiprocessing
8
9 MYP=${PN}-gpl-${PV}
10
11 DESCRIPTION="Provides access to GNAT compiler internals for AdaCore utilities"
12 HOMEPAGE="http://libre.adacore.com"
13 SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a6b
14         -> ${MYP}-src.tar.gz"
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19 IUSE="+shared static-libs static-pic"
20
21 RDEPEND="${ADA_DEPS}"
22 DEPEND="${RDEPEND}
23         dev-ada/gprbuild[${ADA_USEDEP}]"
24 REQUIRED_USE="${ADA_REQUIRED_USE}"
25
26 S="${WORKDIR}"/${MYP}-src
27
28 PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
29
30 src_compile() {
31         emake GNATMAKE="gnatmake ${ADAFLAGS}" \
32                 BUILDER="gprbuild -j$(makeopts_jobs)" generate_sources
33         if use static-libs; then
34                 emake BUILDER="gprbuild -v -j$(makeopts_jobs)" build-static
35         fi
36         for kind in shared static-pic; do
37                 if use ${kind}; then
38                         emake BUILDER="gprbuild -v -j$(makeopts_jobs)" \
39                                 build-${kind}
40                 fi
41         done
42 }
43
44 src_install() {
45         if use static-libs; then
46                 emake prefix="${D}"/usr install-static
47         fi
48         for kind in shared static-pic; do
49                 if use ${kind}; then
50                         emake prefix="${D}"/usr install-${kind}
51                 fi
52         done
53         einstalldocs
54 }