app-vim/vimpress: Switch to PYTHON_MULTI_USEDEP API
[gentoo.git] / app-vim / vimtex / vimtex-99999999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit vim-plugin
7
8 if [[ ${PV} == 9999* ]]; then
9         EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
10         inherit git-r3
11 else
12         inherit vcs-snapshot
13         COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
14         SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
19 HOMEPAGE="https://github.com/lervag/vimtex"
20 LICENSE="MIT"
21
22 VIM_PLUGIN_HELPFILES="${PN}"
23
24 RDEPEND="
25         !app-vim/vim-latex
26         !app-vim/automatictexplugin"
27
28 src_prepare() {
29         default
30
31         # remove unwanted files
32         rm -r *.md media test || die
33 }