app-vim/*: Update Manifest hashes
[gentoo.git] / app-vim / vimoutliner / vimoutliner-0.3.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit vim-plugin
7
8 DESCRIPTION="vim plugin: easy and fast outlining"
9 HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
10 SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
11 LICENSE="GPL-2"
12 KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
13
14 VIM_PLUGIN_HELPFILES="vimoutliner"
15 VIM_PLUGIN_MESSAGES="filetype"
16
17 src_prepare() {
18         default
19         sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
20         sed -i -e 's/g:vo_modules2load/g:vo_modules_load/' vimoutliner/vimoutlinerrc || die
21         rm -v install.sh || die
22         find "${S}" -type f -exec chmod a+r {} \; || die
23 }