app-vim/tcomment: fix git tree for live ebuild
[gentoo.git] / app-vim / tcomment / tcomment-3.08.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit vim-plugin
7
8 MY_PN="tcomment_vim"
9
10 if [[ ${PV} == "9999" ]] ; then
11         EGIT_REPO_URI="https://github.com/tomtom/tcomment_vim.git"
12         inherit git-r3
13 else
14         SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="amd64 x86"
16         S="${WORKDIR}/${MY_PN}-${PV}"
17 fi
18
19 DESCRIPTION="vim plugin: an extensible and universal comment toggler"
20 HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
21 LICENSE="GPL-3"
22
23 VIM_PLUGIN_HELPFILES="${PN}.txt"
24
25 src_prepare() {
26         default
27         rm -r README LICENSE.TXT etc spec addon* || die
28 }