Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / app-vim / syntastic / syntastic-9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit vim-plugin
7
8 if [[ ${PV} == "9999" ]] ; then
9         inherit git-r3
10         EGIT_REPO_URI="https://github.com/scrooloose/syntastic.git"
11 else
12         SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64 ~x86"
14 fi
15
16 DESCRIPTION="vim plugin: syntax checking using external tools"
17 HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
18 LICENSE="WTFPL-2"
19
20 VIM_PLUGIN_HELPFILES="${PN}"
21
22 src_prepare() {
23         rm -r _assets LICENCE README.markdown || die
24 }
25
26 pkg_postinst() {
27         if [[ -z ${REPLACING_VERSIONS} ]] ; then
28                 elog "Syntastic has many optional dependencies depending on the type"
29                 elog "of syntax checking being performed. Look in the related files in"
30                 elog "the syntax_checkers directory to help figure out what programs"
31                 elog "different languages need."
32         fi
33 }