app-vim/nerdtree: EAPI 6 bump.
[gentoo.git] / app-vim / nerdtree / nerdtree-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit vim-plugin
7
8 if [[ ${PV} == "9999" ]] ; then
9         EGIT_REPO_URI="https://github.com/scrooloose/nerdtree.git"
10         inherit git-r3
11 else
12         SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64 ~x86 ~x64-macos"
14 fi
15
16 DESCRIPTION="vim plugin: A tree explorer plugin for navigating the filesystem"
17 HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1658 https://github.com/scrooloose/nerdtree"
18 LICENSE="WTFPL-2"
19
20 VIM_PLUGIN_HELPFILES="NERD_tree"
21
22 src_prepare() {
23         rm LICENCE screenshot.png || die
24         default
25 }