net-firewall/shorewall: Cleanup
[gentoo.git] / app-vim / locateopen / locateopen-1.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit vim-plugin
6
7 DESCRIPTION="vim plugin: open a file without supplying a path"
8 HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=858"
9
10 LICENSE="vim"
11 KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
12 IUSE=""
13
14 RDEPEND="${RDEPEND} sys-apps/mlocate"
15
16 VIM_PLUGIN_HELPTEXT=\
17 "This plugin provides commands that hook vim into mlocate:
18 \    :LocateEdit   filename
19 \    :LocateSplit  filename
20 \    :LocateSource filename
21 \    :LocateRead   filename
22 To configure:
23 \    :let g:locateopen_ignorecase = 1    \" enable ignore case mode
24 \    :let g:locateopen_smartcase = 0     \" disable smart case mode
25 \    :let g:locateopen_alwaysprompt = 1  \" show menu for one match"