www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-vim / gitgutter / gitgutter-20180815.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit vim-plugin
6
7 if [[ ${PV} == 9999* ]]; then
8         EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
9         inherit git-r3
10 else
11         inherit vcs-snapshot
12         COMMIT_HASH="50a7062909d91a290fae04219887b1b45f3138db"
13         SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
14         KEYWORDS="~amd64 ~x86"
15 fi
16
17 DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
18 HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
19 LICENSE="MIT"
20 VIM_PLUGIN_HELPFILES="${PN}.txt"
21
22 RDEPEND="dev-vcs/git"
23
24 src_prepare() {
25         default
26
27         # remove unwanted files
28         rm LICENCE README* screenshot.png unplace.vim || die
29         rm -r test || die
30 }