99da06afb9fbd56d8b213976be6b177123cb06d5
[gentoo.git] / app-vim / fluxbox-syntax / fluxbox-syntax-1.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit vim-plugin
7
8 DESCRIPTION="vim plugin: fluxbox files syntax and indent"
9 HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=679"
10 LICENSE="vim"
11 KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
12
13 RDEPEND="app-vim/genindent"
14
15 VIM_PLUGIN_HELPTEXT=\
16 "This plugin provides syntax highlighting and indent settings for fluxbox
17 menus and similar files. Upstream don't provide us with an ftdetect file,
18 but a simple one has been created for you by this ebuild. You can manually
19 set the filetype using :set filetype=fluxbox if necessary."
20
21 VIM_PLUGIN_MESSAGES="filetype"
22
23 src_prepare() {
24         default
25         mkdir ftdetect || die
26         echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
27                 > ftdetect/fluxbox.vim || die
28 }