f125500033c2d8f02771e35a0c94fdbe2a33b56b
[gentoo.git] / app-vim / bnf-syntax / bnf-syntax-1.2-r2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit vim-plugin
8
9 DESCRIPTION="vim plugin: BNF file syntax highlighting"
10 HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=250"
11 LICENSE="vim.org"
12 KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
13 IUSE=""
14
15 VIM_PLUGIN_HELPTEXT=\
16 "This plugin provides syntax highlighting for BNF files."
17
18 src_prepare() {
19         default
20         # fix hi link to use def, bug #101790.
21         sed -i -e 's,hi link,hi def link,g' syntax/bnf.vim || die "sed failed"
22 }