dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-vim / bnf-syntax / bnf-syntax-1.2-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit vim-plugin
7
8 DESCRIPTION="vim plugin: BNF file syntax highlighting"
9 HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=250"
10 LICENSE="vim.org"
11 KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
12 IUSE=""
13
14 VIM_PLUGIN_HELPTEXT=\
15 "This plugin provides syntax highlighting for BNF files."
16
17 src_prepare() {
18         default
19         # fix hi link to use def, bug #101790.
20         sed -i -e 's,hi link,hi def link,g' syntax/bnf.vim || die "sed failed"
21 }