dev-python/curtsies: x86 stable wrt bug #720482
[gentoo.git] / app-vim / autoalign / autoalign-14.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit vim-plugin
7
8 DESCRIPTION="vim plugin: automatically align bib, c, c++, tex and vim code"
9 HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=884"
10 LICENSE="vim"
11 KEYWORDS="~alpha amd64 ~ia64 ~mips ppc sparc x86"
12 IUSE=""
13
14 if [[ ${PV} != 9999* ]] ; then
15         SRC_URI="mirror://gentoo/${P}.tar.xz
16                 https://dev.gentoo.org/~chutzpah/vim/${P}.tar.xz"
17 fi
18
19 DEPEND="app-arch/xz-utils"
20 RDEPEND="
21         >=app-vim/align-30
22         >=app-vim/cecutil-4"
23
24 VIM_PLUGIN_HELPFILES="autoalign"
25 VIM_PLUGIN_MESSAGES="filetype"
26
27 src_prepare() {
28         # Don't use the cecutil.vim included in the tarball, use the one
29         # provided by app-vim/cecutil instead.
30         rm plugin/cecutil.vim || die
31 }