Use https by default
[gentoo.git] / app-vim / airline / airline-0.5.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit vim-plugin
7
8 if [[ ${PV} != 9999* ]] ; then
9         MY_PN=vim-${PN}
10         MY_P=${MY_PN}-${PV}
11         SRC_URI="https://github.com/bling/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12         KEYWORDS="~amd64 ~x86"
13         S=${WORKDIR}/${MY_P}
14 else
15         inherit git-r3
16         EGIT_REPO_URI="git://github.com/bling/vim-airline.git"
17 fi
18
19 DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
20 HOMEPAGE="https://github.com/bling/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
21 LICENSE="MIT"
22 VIM_PLUGIN_HELPFILES="${PN}.txt"
23
24 src_prepare() {
25         # remove unwanted files
26         rm -rf t Gemfile Rakefile LICENSE README*
27 }