app-text/highlight: Bump to 3.25
[gentoo.git] / app-text / zathura-pdf-poppler / zathura-pdf-poppler-0.2.7.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils toolchain-funcs
7 [[ ${PV} == 9999* ]] && inherit git-2
8
9 DESCRIPTION="PDF plug-in for zathura"
10 HOMEPAGE="http://pwmt.org/projects/zathura/"
11 if ! [[ ${PV} == 9999* ]]; then
12 SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
13 fi
14 EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
15 EGIT_BRANCH="develop"
16
17 LICENSE="ZLIB"
18 SLOT="0"
19 if ! [[ ${PV} == 9999* ]]; then
20 KEYWORDS="~amd64 arm ~x86"
21 fi
22 IUSE=""
23
24 RDEPEND="app-text/poppler:=[cairo]
25         >=app-text/zathura-0.2.7
26         x11-libs/cairo:="
27 DEPEND="${RDEPEND}
28         virtual/pkgconfig"
29
30 pkg_setup() {
31         myzathuraconf=(
32                 CC="$(tc-getCC)"
33                 LD="$(tc-getLD)"
34                 VERBOSE=1
35                 DESTDIR="${D}"
36         )
37 }
38
39 src_compile() {
40         emake "${myzathuraconf[@]}"
41 }
42
43 src_install() {
44         emake "${myzathuraconf[@]}" install
45         dodoc AUTHORS
46 }