app-text/xapian-omega: version bump to 1.4.5
[gentoo.git] / app-text / zathura-cb / zathura-cb-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils toolchain-funcs readme.gentoo-r1
7 [[ ${PV} == 9999* ]] && inherit git-2
8
9 DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
10 HOMEPAGE="http://pwmt.org/projects/zathura/"
11 if ! [[ ${PV} == 9999* ]]; then
12 SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
13 fi
14 EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
15 EGIT_BRANCH="develop"
16
17 LICENSE="ZLIB"
18 SLOT="0"
19 if ! [[ ${PV} == 9999* ]]; then
20 KEYWORDS="~amd64 ~arm ~x86"
21 else
22 KEYWORDS=""
23 fi
24 IUSE=""
25
26 RDEPEND=">=app-text/zathura-0.3.1
27         dev-libs/glib:2=
28         app-arch/libarchive:=
29         x11-libs/cairo:=
30         x11-libs/gdk-pixbuf:="
31 DEPEND="${RDEPEND}
32         virtual/pkgconfig"
33
34 pkg_setup() {
35         myzathuraconf=(
36                 CC="$(tc-getCC)"
37                 LD="$(tc-getLD)"
38                 VERBOSE=1
39                 DESTDIR="${D}"
40         )
41 }
42
43 src_compile() {
44         emake "${myzathuraconf[@]}"
45 }
46
47 src_install() {
48         emake "${myzathuraconf[@]}" install
49         dodoc AUTHORS
50         readme.gentoo_create_doc
51 }
52
53 pkg_postinst() {
54         readme.gentoo_print_elog
55 }
56
57 FORCE_PRINT_ELOG=1
58 DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
59 app-arch/unzip for additional file support."