app-admin/hddtemp: remove quote too many
[gentoo.git] / app-text / yodl / yodl-3.08.02.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
9 HOMEPAGE="https://fbb-git.github.io/yodl/ https://github.com/fbb-git/yodl"
10 SRC_URI="https://github.com/fbb-git/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc"
16
17 DEPEND=">=dev-util/icmake-8.00.00"
18
19 S=${WORKDIR}/${P}/${PN}
20
21 src_prepare() {
22         sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
23                 -e "/COMPILER =/s/gcc/$(tc-getCC)/" \
24                 -e "/CXX =/s/g++/$(tc-getCXX)/" \
25                 -i INSTALL.im || die
26
27         sed -e "s/ar r /$(tc-getAR) r /" \
28                 -e "s/ranlib/$(tc-getRANLIB)/" \
29                 -i icmake/stdcompile || die
30
31         default
32 }
33
34 src_compile() {
35         ./build programs || die
36         ./build macros || die
37         ./build man || die
38         use doc && { ./build manual || die ; }
39 }
40
41 src_install() {
42         ./build install programs "${ED}" || die
43         ./build install macros "${ED}" || die
44         ./build install man "${ED}" || die
45         ./build install docs "${ED}" || die
46         use doc && { ./build install manual "${ED}" || die ; }
47 }