Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / app-text / xmlstarlet / xmlstarlet-1.5.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
8 HOMEPAGE="http://xmlstar.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/xmlstar/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
14 IUSE=""
15
16 RDEPEND=">=dev-libs/libxml2-2.6.27
17         >=dev-libs/libxslt-1.1.9
18         dev-libs/libgcrypt:0
19         virtual/libiconv"
20
21 DEPEND="${RDEPEND}
22         sys-apps/sed"
23
24 src_configure() {
25         # NOTE: Fully built documentation is already shipped with the tarball:
26         # - doc/xmlstarlet-ug.{pdf,ps,html}
27         # - doc/xmlstarlet.txt
28         # - doc/xmlstarlet.1
29         econf \
30                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
31                 --disable-build-docs \
32                 --disable-static-libs \
33                 --disable-silent-rules
34 }
35
36 src_install() {
37         default
38
39         dosym xml /usr/bin/xmlstarlet
40 }