app-text/xml2doc: Port to EAPI 7
[gentoo.git] / app-text / xml2doc / xml2doc-20030510-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
9 HOMEPAGE="http://xml2doc.sourceforge.net"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
15
16 DEPEND="dev-libs/libxml2:2"
17 RDEPEND="${DEPEND}"
18
19 S="${WORKDIR}/${PN}"
20
21 PATCHES=(
22         # Fix pointer-related bug detected by a QA notice
23         "${FILESDIR}"/${PN}-pointer_fix.patch
24         # Don't strip symbols from binary (bug #152266)
25         "${FILESDIR}"/${P}-makefile.patch
26 )
27
28 src_configure() {
29         tc-export CC
30         econf --disable-pdf
31 }
32
33 src_compile() {
34         default
35
36         cd doc || die
37         "${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die
38 }
39
40 src_install() {
41         dobin src/xml2doc
42
43         einstalldocs
44         docinto examples
45         dodoc examples/*.{xml,png}
46
47         doman doc/xml2doc.1
48 }