app-text/libmwaw: arm64 stable wrt bug #716822
[gentoo.git] / app-text / xlsx2csv / xlsx2csv-0.7.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5 PYTHON_COMPAT=( python{3_6,3_7} )
6 PYTHON_REQ_USE="xml"
7
8 inherit distutils-r1
9
10 DESCRIPTION="Convert MS Office xlsx files to CSV"
11 HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="dev-lang/perl"
19
20 PATCHES=( "${FILESDIR}"/${P}-tests.patch )
21
22 python_compile_all() {
23         emake -C man
24 }
25
26 python_test() {
27         "${PYTHON}" test/run || die "tests failed with ${EPYTHON}"
28 }
29
30 python_install_all() {
31         distutils-r1_python_install_all
32         doman man/${PN}.1
33 }