Merge the GLEP 67 transition changes
[gentoo.git] / app-text / xlsx2csv / xlsx2csv-0.6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python{2_7,3_3} )
7 PYTHON_REQ_USE="xml"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Convert MS Office xlsx files to CSV"
12 HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 DEPEND="dev-lang/perl"
20
21 python_compile_all() {
22         emake -C man
23 }
24
25 python_install_all() {
26         distutils-r1_python_install_all
27         doman man/${PN}.1
28 }