www-plugins/chrome-binary-plugins: automated update
[gentoo.git] / app-text / xapian-omega / xapian-omega-1.4.15.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
7 SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
8 HOMEPAGE="https://xapian.org/"
9 S="${WORKDIR}/xapian-omega-${PV}"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
14 IUSE=""
15
16 DEPEND="dev-libs/xapian:0/30
17         dev-lang/perl
18         dev-libs/libpcre
19         sys-libs/zlib"
20 RDEPEND="${DEPEND}"
21
22 src_install() {
23         emake DESTDIR="${D}" install
24
25         # Protect /etc/omega.conf
26         echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
27         doenvd "${T}"/20xapian-omega
28         dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
29
30         # Directory containing Xapian databases:
31         keepdir /var/lib/omega/data
32
33         # Directory containing OmegaScript templates:
34         keepdir /var/lib/omega/templates
35         mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
36
37         # Directory to write Omega logs to:
38         keepdir /var/log/omega
39
40         # Directory containing any cdb files for the $lookup OmegaScript command:
41         keepdir /var/lib/omega/cdb
42 }