dev-python/virtualenv: arm64 keyworded (bug #700918)
[gentoo.git] / app-text / wv2 / wv2-0.4.2-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils flag-o-matic
7
8 DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
9 HOMEPAGE="http://wvware.sourceforge.net"
10 SRC_URI="mirror://sourceforge/wvware/${P}.tar.bz2"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
15 IUSE="zlib"
16
17 RDEPEND="
18         dev-libs/glib
19         >=gnome-extra/libgsf-1.8:=
20         virtual/libiconv
21         zlib? ( sys-libs/zlib )"
22 DEPEND="
23         ${RDEPEND}"
24
25 PATCHES=(
26         "${FILESDIR}"/${P}-glib.patch
27         "${FILESDIR}"/${P}-libgsf.patch
28 )
29 DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
30
31 src_configure() {
32         # due to ICU 59 requiring C++11 now
33         append-cxxflags -std=c++11
34
35         local mycmakeargs=(
36                 -DWITH_ZLIB=$(usex zlib)
37         )
38         cmake-utils_src_configure
39 }