app-text/libmwaw: arm64 stable wrt bug #716822
[gentoo.git] / app-text / wdiff / wdiff-1.2.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Create a diff disregarding formatting"
7 HOMEPAGE="https://www.gnu.org/software/wdiff/"
8 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
13 IUSE="experimental test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         sys-apps/diffutils
18         sys-apps/less
19         sys-libs/ncurses"
20 DEPEND="${RDEPEND}
21         test? ( app-misc/screen )"
22
23 src_configure() {
24         econf \
25                 $(use_enable experimental)
26 }
27
28 src_test() {
29         # The test suite hangs in the '3: use pager' test
30         # when an incompatible screenrc is found
31         touch tests/screenrc || die
32         export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
33         default
34 }