app-text/ghostscript-gpl-9.26: arm64 stable (bug #668846)
[gentoo.git] / app-text / uudeview / uudeview-0.5.20-r2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils autotools
7
8 DESCRIPTION="uu, xx, base64, binhex decoder"
9 HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
10 SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
15 IUSE=""
16
17 RDEPEND=""
18 DEPEND=""
19
20 DOCS=( HISTORY INSTALL README )
21
22 PATCHES=(
23         "${FILESDIR}/${P}-bugfixes.patch"
24         "${FILESDIR}/${P}-CVE-2004-2265.patch"
25         "${FILESDIR}/${P}-CVE-2008-2266.patch"
26         "${FILESDIR}/${P}-man.patch"
27         "${FILESDIR}/${P}-rename.patch"
28         "${FILESDIR}/${P}-makefile.patch"
29 )
30
31 src_prepare() {
32         epatch "${PATCHES[@]}"
33
34         mv configure.in configure.ac || die
35
36         epatch_user
37         eautoreconf
38 }
39
40 src_configure() {
41         econf \
42                 --disable-tcl \
43                 --disable-tk
44 }