acct-group/clair: add clair group
[gentoo.git] / app-text / uudeview / uudeview-0.5.20-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="uu, xx, base64, binhex decoder"
9 HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
10 SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
15
16 PATCHES=(
17         "${FILESDIR}"/${P}-bugfixes.patch
18         "${FILESDIR}"/${P}-CVE-2004-2265.patch
19         "${FILESDIR}"/${P}-CVE-2008-2266.patch
20         "${FILESDIR}"/${P}-man.patch
21         "${FILESDIR}"/${P}-rename.patch
22         "${FILESDIR}"/${P}-makefile.patch
23 )
24
25 DOCS=( HISTORY INSTALL README )
26
27 src_prepare() {
28         default
29         mv configure.{in,ac} || die
30         eautoreconf
31 }
32
33 src_configure() {
34         econf \
35                 --disable-tcl \
36                 --disable-tk
37 }