app-text/ttf2pk2: x86 stable wrt bug #432144
[gentoo.git] / app-text / ttf2pk2 / ttf2pk2-1.5_p20120701.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
8 HOMEPAGE="http://tug.org/texlive/"
9 SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE=""
15
16 # Note about blockers: it is a freetype2 based replacement for ttf2pk and
17 # ttf2tfm from freetype1, so block freetype1.
18 # It installs some data that collides with
19 # dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
20 # meanwhile we can start dropping freetype1.
21 RDEPEND=">=dev-libs/kpathsea-6.0.1_p20110627
22                 media-libs/freetype:2
23                 sys-libs/zlib
24                 !media-libs/freetype:1
25                 !=dev-texlive/texlive-langcjk-2011*[source]"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig"
28
29 S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
30
31 src_configure() {
32         econf --with-system-kpathsea \
33                 --with-system-freetype2 \
34                 --with-system-zlib
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install
39         dodoc BUGS README TODO ChangeLog
40 }