proj/gentoo: Initial commit
[gentoo.git] / app-text / tree / tree-1.7.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit toolchain-funcs flag-o-matic bash-completion-r1
7
8 DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
9 HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
10 SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
15 IUSE=""
16
17 RDEPEND="!=sci-biology/meme-4.8.1"
18 DEPEND=""
19
20 src_prepare() {
21         sed -i -e 's:LINUX:__linux__:' tree.c || die
22         mv doc/tree.1.fr doc/tree.fr.1
23         if use !elibc_glibc ; then
24                 # 433972, also previously done only for elibc_uclibc
25                 sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
26         fi
27 }
28
29 src_compile() {
30         append-lfs-flags
31         emake \
32                 CC="$(tc-getCC)" \
33                 CFLAGS="${CFLAGS} ${CPPFLAGS}" \
34                 LDFLAGS="${LDFLAGS}"
35 }
36
37 src_install() {
38         dobin tree
39         doman doc/tree*.1
40         dodoc CHANGES README*
41         newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
42 }