Merge remote-tracking branch 'github/pr/760'.
[gentoo.git] / app-text / tokyodystopia / tokyodystopia-0.9.15.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
10 HOMEPAGE="http://fallabs.com/tokyodystopia/"
11 SRC_URI="${HOMEPAGE}${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="examples"
17
18 DEPEND="dev-db/tokyocabinet"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         epatch "${FILESDIR}/fix_rpath.patch"
23         epatch "${FILESDIR}/fix_ldconfig.patch"
24         epatch "${FILESDIR}/remove_docinst.patch"
25 }
26
27 src_configure() {
28         econf --libexecdir=/usr/libexec/${PN} || die
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "Install failed"
33
34         dohtml doc/* || die
35
36         if use examples; then
37                 insinto /usr/share/${PF}/example
38                 doins example/* || die "Install failed"
39         fi
40
41 }
42
43 src_test() {
44         emake -j1 check || die "Tests failed"
45 }